Ask a Question

Advanced Search

Alert ID : GN221222001953

Last Modified : 01/25/2023

Compatibility of DigiCert Trusted Root Certificates

Description

DigiCert’s Trusted Root Certificates (DigiCert Global Root CA and DigiCert Global Root G2) are compatible with all modern browsers and platforms.

 

The table below details the minimum version requirement for each browser and platform to be compatible with DigiCert’s Trusted Root Certificates.

Platform OS/Browser DigiCert Global Root CA version requirement DigiCert Global Root G2 version requirement
Microsoft

Internet Explorer

Microsoft Edge

Google Chrome

Windows XP SP3+ Windows XP SP3+
Apple Safari/Chrome for Mac OS X Mac OS X 10.6+ Mac OS X 10.10+
  Safari/Chrome for iOS iOS 4.0+ iOS 7.0+
Mozilla Firefox

Firefox 2+

NSS 3.11.8

Firefox 32+

NSS 3.16.3

Google Android Android 1.1+ Android 5.0+
Oracle Java JRE 1.4.2_17+ JRE1.8.0_131+



For a full list of DigiCert’s Root and Intermediate Certificates, please visit:
https://www.digicert.com/kb/digicert-root-certificates.htm