Ask a Question

Solution ID : SO19646

Last Modified : 05/02/2018

Error: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) when trying to Complete Certificate Request in Microsoft IIS 7

Problem

Cause

This could possibly be a system permission issue within Microsoft 2008 IIS 7 Server.

Solution

This solution describes how you can resolve your issue using a workaround of installing your certificate without using the Complete Certificate Request feature IIS 7.

To download your RapidSSL certificate, please use one of the the following options below:

Method1:
RapidSSL will send you the SSL certificate via email.
 
Using a plain text editor such as Notepad, paste the content of the certificate:
 
You should then have a text file that looks like:
 
-----BEGIN CERTIFICATE-----
[encoded data]
-----END CERTIFICATE-----
 
Make sure you have 5 dashes to either side of the BEGIN CERTIFICATE and END CERTIFICATE and that no white space, extra line breaks or additional characters have been inadvertently added.
 
Please save the Certificate file as a .cer extension.
 
Method 2:
Download the certificate in X509 format from RapidSSL : SO16222

To install the certificate, please follow the instructions listed below:

1.  Save file as .cer
2.  Right click on the certificate file
3.  Select Install Certificate
4.  The Certificate Import Wizard will open, select Next
5.  Select the "Place all certificates in the following store", select Browse, select Personal, then select OK

Once installed to add an HTTPS binding to a Web site in IIS7, you need to bind the HTTPS protocol to a Web site and then assign the installed certificate:

1.  Click Start > Administrative Tools > Internet Information Services (IIS) Manager
2.  Browse to your server name > Sites > Your SSL-based site
3.  From the Actions pane, choose Bindings
4.  In the Site Bindings window, choose Add
5.  From the Add Site Bindings window, provide the binding type
6.  Select the SSL certificate that will be used for this site
7.  Click OK

To find more information on this issue, please visit Microsoft's website - http://support.microsoft.com/search/?adv=1