Ask a Question

Solution ID : SO22316

Last Modified : 05/02/2018

Error: Renewal Failed | New Enrollment Failed during Enrollment of Microsoft Authenticode or Office and VBA Certificates using Internet Explorer 8, 9 or 10

Problem

When enrolling or renewing a Microsoft Authenticode or a Microsoft Office and VBA certificate using IE 8, 9 or 10 on Microsoft Windows 8, the following error may occur:

Renewal failed.

or

New enrollment failed.

Cause

The local key gen fails due to certain browser settings.

Solution

The error can be corrected by changing Internet Explorer's (IE) browser settings.

Step 1:  Add the Thawte Enrollment Site to IE's Trusted Sites List

To add Thawte's enrollment site to the trusted sites list, perform the following steps:

  1. In IE, click Tools > Internet Options

  2. Click Security tab > select Trusted sites as the zone, then click the Sites button



     
  3. Under Add this website to the zone, enter the following:

    ssl-certificate-center.thawte.com
     
  4. Click Add

    NOTE: If the Add button is grayed out, consult your local IT Administrator to add a site to the trusted sites list
     
  5. Open a new IE browser window and try the enrollment again
     

Step 2:  Perform Enrollment in IE's Compatibility Mode

Perform the following steps if the error message continues or if you are not prompted, "Allow this site to generate a key" after Step 1 has been attempted.

To turn IE's Compatibility Mode on, perform the following steps:

  1. In IE, click Tools > Compatibility View settings
  2. Check the option box for Display all websites in Compatiblity View
  3. Click Close > OK
  4. Open a new IE browser window and try the enrollment again
     

Step 3:  Change Browser Mode to IE version 8 or 9

Perform the following steps if the error message continues or if you are not prompted, "Allow this site to generate a key" after Step 1 and Step 2 have been attempted.

To change Browser Mode to IE version 8 or 9, perform the following steps:

  1. In IE, click Tools > Developer Tools
  2. Select Browser Mode > then choose either Internet Explorer 8 or Internet Explorer 9
  3. Using the same IE window start the enrollment from the beginning